United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Weather Delay] Multiple Counties - California

Incident Report for Checkr US Data Status

Resolved

Weather conditions have improved and research is expected to return to normal.
Posted Jan 18, 2023 - 16:20 UTC

Update

Severe weather conditions are causing delays on searches; Alameda, Santa Clara, San Benito and Monterey. Due to the road conditions and severity of the storm, please expect delays. We anticipate several California jurisdictions being impacted by the inclement weather and will continue to notify you of any changes.
Posted Jan 10, 2023 - 00:42 UTC

Monitoring

Severe weather conditions are causing delays on searches with possible records in Alameda and Santa Clara. Due to the road conditions and severity of the storm, please expect delays. We anticipate several California jurisdictions being impacted by the inclement weather and will continue to notify you of any changes.
Posted Jan 06, 2023 - 00:37 UTC