United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

WA DMV Scheduled Maintenance

Incident Report for Checkr US Data Status

Update

The WA DOL is back online. We will continue to monitor records until the maintenance completion date of February 20th.
Posted Feb 18, 2025 - 15:47 UTC

Monitoring

The WA Department of Licensing (DOL) is upgrading its driver and vehicle licensing system beginning February 9, 2025. Access for MVRs will be unavailable starting at 8:30 pm PST on Sunday, February 9. We expect service to be fully restored by February 20 at 12 pm PST.
Posted Feb 09, 2025 - 13:55 UTC