[Planned Outage] Weekend DMV Scheduled Maintenance
Incident Report for Checkr Data Status
Resolved
This incident has been resolved.
Posted Jan 23, 2023 - 18:26 UTC
Identified
The following DMVs will be performing scheduled maintenance this weekend during these times:

Saturday, 1/21
Utah: 12-1pm PT

Sunday, 1/22
Minnesota: 5-7am PT
Alaska: 8-10am PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Jan 20, 2023 - 19:13 UTC