United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Tennessee DMV Scheduled Maintenance

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Aug 26, 2024 - 21:14 UTC

Monitoring

The Tennessee DMV will be performing scheduled maintenance tomorrow from 10PM - 4AM PT. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Aug 22, 2024 - 17:37 UTC