Data Status Page

This page contains information about third-party data source disruptions and delays.

Tuscarawas County, Ohio – Court Processing Delays

Incident Report for Checkr Data Status

Resolved

Updates for Tuscarawas, OH will be combined with and tracked in the "Ohio Multi County - Court Processing Delays" incident.
Posted Aug 20, 2026 - 21:51 UTC

Update

Updates to the Tuscarawas County, Ohio court portal have impacted automated search processing. Searches continue to process, though some delays are expected. There is no ETA for resolution at this time.
Posted Aug 18, 2026 - 21:03 UTC

Monitoring

System instability has taken automated search processing offline. Please expect delays. No ETA for resolution at this time.
Posted Jul 31, 2026 - 21:20 UTC