United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Kent, MI

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted 7 days ago. May 02, 2025 - 15:00 UTC

Update

Automation has been restored and searches are processing.
Posted 9 days ago. Apr 30, 2025 - 15:15 UTC

Update

The site is back online and searches are being processed manually. We are continuing to monitor the situation.
Posted 11 days ago. Apr 28, 2025 - 15:16 UTC

Monitoring

The Kent MI Circuit court portal is currently down for maintenance with no ETA for restoration. Searches are not processing at this time. We are monitoring the situation.
Posted 14 days ago. Apr 25, 2025 - 16:09 UTC