United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[DELAY] - Mid-Atlantic Weather Closures

Incident Report for Checkr US Data Status

Update

We have been alerted to weather related closures in the following counties:

West Virginia (WV): McDowell

Please anticipate delays. We are monitoring the situation.
Posted Feb 21, 2025 - 12:00 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 19, 2025 - 20:08 UTC

Update

We have been alerted to weather related closures in the following counties:

Mississippi (MS): Prentiss, Lee, Monroe

West Virginia (WV): Boone, Lincoln, Logan, Migno, McDowell, Pocahontas

Kentucky (KY): Allen, Ballard, Barren, Breathitt, Bullitt, Caldwell, Calloway, Carlisle, Christian, Crittenden, Fulton, Graves, Hardin, Hickman, Letcher, Marshall, McCracken, Metcalfe, Powell, Simpson, Webster, Wolfe

Tennessee (TN): Knox, Chester, McNairy, Decatur, Hardin, Henderson, Fentress, Warren, Smith, Marshall, Moore, DeKalb, Clay, Overton, Gibson- Humboldt, Fayette, Hardeman, Loudon, Madison

Missouri (MO): ALL

Arkansas (AR): Saline District

We are monitoring the situation.
Posted Feb 19, 2025 - 16:16 UTC

Monitoring

We have been alerted to weather related closures in Pike and Floyd, Kentucky and a handful of to be determined Arkansas counties. We are monitoring the situation and anticipate courts to reopen tomorrow. Please anticipate delays.
Posted Feb 18, 2025 - 21:05 UTC