United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Indiana DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 18, 2022 - 15:42 UTC
Identified
The Indiana DMV will be performing scheduled maintenance today from 3:30-8pm PT. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Nov 17, 2022 - 18:26 UTC