United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Orleans, LA

Incident Report for Checkr US Data Status

Update

The Orleans, LA Parish Sheriff's Office is back online after experiencing website issues. Searches have resumed processing however please anticipate delays as we work through the backlog. We are monitoring the situation.
Posted May 09, 2025 - 14:33 UTC

Update

The Orleans, LA Parish Sheriff's Office is back online after experiencing website issues. Searches have resumed processing however we will continue to monitor the situation.
Posted May 08, 2025 - 16:32 UTC

Update

The Orleans, LA Parish Sheriff's Office is experiencing intermittent issues with their website and searches are currently not processing. We are monitoring the situation.
Posted May 07, 2025 - 21:07 UTC

Update

The Orleans, LA Parish Sheriff's Office is back online and searches are processing as normal. Please continue to anticipate delays as we work through the backlog.
Posted May 05, 2025 - 13:56 UTC

Update

The Orleans, LA Parish Sheriff's Office is experiencing intermittent issues and searches are delayed. We are monitoring the situation.
Posted May 01, 2025 - 15:07 UTC

Monitoring

The Orleans, LA Parish Sheriff's Office is experiencing intermittent issues and searches are delayed. We are monitoring the situation.
Posted Apr 28, 2025 - 15:26 UTC