United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jan 09, 2023 - 17:14 UTC
Identified
The following DMVs will be performing scheduled maintenance during these times on Sunday, 1/8:

Florida: 3-10am PT
Pennsylvania: 5:30am-2:50pm PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Jan 06, 2023 - 19:14 UTC