United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay - Coronavirus] International Criminal Searches and Employment/Education Verifications
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Mar 21, 2022 - 22:16 UTC
Monitoring
04/16/2021 Update

International Criminal: Some countries have opened but will still be experiencing some delays, including Puerto Rico, Bermuda, Canada Provincial jurisdictions, Australia, and United Kingdom.

International Verifications: International employment/education verifications may also be intermittently delayed depending on school/business closures due to COVID; verification attempts are continuing to be made.
Posted Apr 16, 2021 - 16:43 UTC
Update
Please expect delays for criminal orders out of: China, Guam, Germany, Italy, France, Spain, and Poland.
Posted Apr 02, 2020 - 00:53 UTC
Update
In addition to delays in China and Italy, please expect delays for criminal orders out of Poland.
Posted Mar 17, 2020 - 22:53 UTC
Identified
Expected Fix Date: TBD

Please expect delays for criminal orders out of China and Italy. International employment/education verifications may also be intermittently delayed depending on school/business closures at the time verification attempts are being made.
Posted Mar 13, 2020 - 20:19 UTC