United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Shelby, TN

Incident Report for Checkr US Data Status

Update

The Shelby County, TN Court website is back up and normal operations have resumed.
Posted Mar 25, 2025 - 14:17 UTC

Monitoring

The Shelby County, TN Court website is currently down, with restoration tentatively expected before March 26th. Orders requiring automation will experience delays until the site is back online. We are actively monitoring the situation and will provide updates as they become available.
Posted Mar 24, 2025 - 19:41 UTC