United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Wyoming DMV is Offline
Incident Report for Checkr US Data Status
Resolved
The Wyoming DMV is back online and MVRs are once again processing as normal.
Posted May 15, 2023 - 23:02 UTC
Identified
The Wyoming DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted May 15, 2023 - 19:18 UTC