United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted May 10, 2024 - 17:23 UTC
Identified
The Indiana DMV will be performing scheduled maintenance today from 3:30-8pm PT. Additionally, the Colorado DMV will be performing scheduled maintenance today from 8-11pm PT.

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted May 09, 2024 - 17:53 UTC