Data Status Page

This page contains information about third-party data source disruptions and delays.

Spalding County, Georgia – Court Processing Delays

Incident Report for Checkr Data Status

Resolved

Normal processing has resumed. No further delays are expected at this time.
Posted Jul 27, 2026 - 15:53 UTC

Monitoring

Spalding County, GA is currently experiencing processing delays that may impact certain search requests. No ETA at this time.
Posted Jul 14, 2026 - 16:41 UTC