United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Louisiana DMV is Offline
Incident Report for Checkr US Data Status
Resolved
The Louisiana DMV is back online and MVRs are once again processing as normal.
Posted May 19, 2023 - 16:04 UTC
Identified
The Louisiana DMV has been offline since last night and MVRs are unavailable at this time. The state is working to resolve the outage, but there's no ETA at this time. We will send out another notification as soon as we have more information to share.
Posted May 18, 2023 - 16:04 UTC