United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Upcoming DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 23:28 UTC
Identified
The following DMVs will be performing scheduled maintenance tomorrow, 4/23, during these times:

- Oregon: 8-9am PT
- Maine: 3-4pm PT

MVRs requested during these times will not be completed until the scheduled maintenance is completed.
Posted Apr 22, 2024 - 21:55 UTC