United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Severe Weather Advisory - Massachusetts

Incident Report for Checkr US Data Status

Resolved

Massachusetts courts have reopened and normal operations have resumed. This incident is now resolved.
Posted Jan 29, 2026 - 20:05 UTC

Monitoring

All Massachusetts courts are closed on 1/26 due to severe weather. Delays are expected until normal operations resume.
Posted Jan 26, 2026 - 22:18 UTC