United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Montana DMV is Offline
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 21, 2023 - 16:55 UTC
Update
The state has informed us that the outage is related to maintenance and that service will be restored on Monday, November 13. MVRs in MT will be unavailable until maintenance has been completed.
Posted Nov 10, 2023 - 16:56 UTC
Identified
The Montana DMV is currently offline and MVRs in the state are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Nov 09, 2023 - 19:25 UTC