United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Mississippi Driving Record Delayed Service

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 03:25 UTC

Identified

We’re aware of an issue affecting the processing and completion of driving record requests in Mississippi. We’ve contacted the State of Mississippi for more information and will share updates as soon as they become available.
Posted Feb 03, 2026 - 22:39 UTC