United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Summit County, Ohio – Court Processing Delays

Incident Report for Checkr US Data Status

Update

Automated search processing has been restored in Summit County. Some searches may continue to experience delays as the remaining backlog clears. The backlog is expected to clear by June 12.
Posted Jun 10, 2026 - 16:22 UTC

Monitoring

Intermittent disruptions to court system access are impacting some automated search processing. Most searches are processing normally; however, some may experience delays. There is currently no ETA for resolution.
Posted Jun 02, 2026 - 13:55 UTC