United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Pike, KY

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 15:15 UTC

Monitoring

The court in Pike, KY will be closed from 4/23-4/25 for a county wide festival. Searches will resume when courts re-open on 4/28.
Posted Apr 23, 2025 - 19:34 UTC