United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

General Court Delays

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 21:56 UTC

Monitoring

Counties and States experiencing an ongoing delay due to updated processing, staffing, etc.

--AZ: Mohave - The courts have limited staffing, all searches with potential records please expect some delays.

--CA: Kern- The court's PATs have been experiencing intermittent issues. Please expect delays on some orders.

--CA: Los Angeles- The court's PATs have been experiencing intermittent issues. Please expect delays on some orders.

--CA: Napa- The court's PATs have been experiencing intermittent issues, cases with possible cases will be delayed.

--CA: Riverside- The court's PATs have been experiencing intermittent issues. Please expect delays on some orders.

--KY: Simpson- The public access terminal is down and there is currently no known ETA for when it will be restored. Searches cannot be completed at this time.

--KY: Floyd & Knox- Floyd county is closed and searches are unable to complete from 10/6-10/10 due to a festival in town. Knox is closed from 10/9-10/10. Searches for both courthouses will resume Monday 10/13.

--MI: The researchers automation is now fixed across the state, but please expect delays as the researchers catch up in all counties.
Posted Oct 10, 2025 - 21:02 UTC