United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Franklin, NY

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 15:46 UTC

Update

The clerk in Franklin, NY was out of office from 2/26 to 3/5. Searches are now processing as normal but we are still working through the backlog. We are monitoring the progress.
Posted Mar 10, 2025 - 16:12 UTC

Monitoring

The clerk in Franklin, NY is out of office until 3/6. Searches will not be processed during this time. We are monitoring the situation.
Posted Mar 05, 2025 - 17:46 UTC