United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delays] - Hawaii
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Sep 06, 2023 - 21:33 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 28, 2023 - 23:31 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 17, 2023 - 17:37 UTC
Monitoring
Maui has recently suffered from the devastation of wildfires on the island. As other counties across the state plan to support Maui, expect delays statewide. We will continue to monitor the situation and notify you of any changes.
Posted Aug 10, 2023 - 23:17 UTC