Data Status Page

This page contains information about third-party data source disruptions and delays.

Massachusetts Statewide – Court Processing Delays

Incident Report for Checkr Data Status

Update

Normal search processing has resumed. Some searches may experience delays while the queue clears. No ETA at this time.
Posted Aug 07, 2026 - 18:45 UTC

Update

Normal search processing has resumed. Some searches may experience delays while the queue clears. No ETA at this time.
Posted Jul 30, 2026 - 21:45 UTC

Monitoring

Due to system instability. Some searches may experience delays. No ETA for resolution at this time.
Posted Jul 20, 2026 - 21:15 UTC