United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[DELAY] - Elbert, GA

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 22:01 UTC

Monitoring

The website in Elbert County, GA is currently down and no searches can be processed at this time. There is no ETA for restoration. We are monitoring the situation.
Posted Feb 14, 2025 - 20:06 UTC