United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Sep 03, 2024 - 19:12 UTC
Monitoring
The MD DMVs will be performing scheduled maintenance during these times on Saturday at 11PM - Sunday at 4AM. MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Aug 30, 2024 - 16:07 UTC