United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Jefferson, WV
Incident Report for Checkr US Data Status
Resolved
8/2/2022: The court in Jefferson, WV is back open and searches will now be completed.
Posted Aug 02, 2022 - 14:11 UTC
Monitoring
07/29/2022: The court in Jefferson, WV is closed today and Monday, August 1st, due to a Covid exposure among employees. No searches will be processed until the court reopens. The court plans to reopen on August 2nd, but we will continue to monitor this and notify you of any changes.
Posted Jul 29, 2022 - 19:51 UTC