United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Carson City, NV

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 14:33 UTC

Update

The clerk in Carson City, Nevada is back in office following an extended leave. Please continue to anticipate delays as we work through the backlog.
Posted Apr 18, 2025 - 15:44 UTC

Monitoring

The clerk in Carson City, Nevada is out of office until 4/14/2025. Please anticipate delays.
Posted Apr 14, 2025 - 15:21 UTC