United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Hurricane Debby Closures and Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Aug 22, 2024 - 17:06 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 16, 2024 - 16:20 UTC
Update
We are continuing to monitor for any further issues.
Posted Aug 15, 2024 - 20:01 UTC
Update
Jenkins, GA county courthouse is still closed due to flooding during Hurricane Debby. All other courthouses have reopened and searches are processing. Please expect some delays as researchers work through orders and we will keep you updated.
Posted Aug 13, 2024 - 20:42 UTC
Monitoring
Some counties in GA have reopened and searches are being processed, but continue to see some delays as courts recover. We are still seeing delays and closures in the following areas:

GA: Courts in Brooks, Bryan, Bulloch, Effingham, Evans, Jenkins, Liberty, Long, & Screven are still closed and searches cannot be conducted.
SC: Possible delays on some searches.

We will continue to notify you of any updates.
Posted Aug 08, 2024 - 19:41 UTC
Identified
Hurricane Debby is expected to cause power outages, flooding, road closures, court delays, and closures. Please see below the known affected counties and states.

-GA: Courts closed in Appling, Atkinson, Bacon, Berrien, Brantley, Brooks, Bryan, Bulloch, Camden, Candler, Clinch, Cook, Evans, Chatham, Glynn, Lanier, Liberty, Long, McIntosh, Mitchell, Tattnall, Thomas, Tift, Screven, Pierce, Ware, & Wayne. No searches will be completed until the courts reopen.
-SC: Possible delays on some searches.

We will continue to monitor this and notify you of any additional counties affected.
Posted Aug 06, 2024 - 21:19 UTC