United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[DELAY] MID ATLANTIC STORM COURT CLOSURES
Incident Report for Checkr US Data Status
Resolved
All courts are back open.
Posted Jan 09, 2025 - 17:27 UTC
Update
Court status updates related to the winter storm in the Mid-Atlantic region for 1/8/2025:

All Delaware, D.C and West Virginia courts are back open.


Kentucky courts that are closed: Boyd, Bullitt, Estill.
Posted Jan 08, 2025 - 10:15 UTC
Monitoring
Due to the ongoing winter storm in the Mid Atlantic region the following courts are closed for 1/6/2025.

West Virgina:
Barbour, Berkeley, Boone, Braxton, Brooke, Cabell, Calhoun, Clay, Doddridge, Fayette, Gilmer, Grant, Greenbrier, Hampshire, Hancock, Hardy, Harrison, Jackson, Jefferson, Kanawha, Lewis, Lincoln, Logan, Marion, Marshall, Mason, Mercer, Mineral, Mingo, Monongalia, Monroe, Morgan, Nicholas, Ohio, Pendleton, Pleasants, Pocahontas, Preston, Putnam, Raleigh, Randolph, Ritchie, Roane, Summers, Taylor, Tucker, Tyler, Upshur, Wayne, Webster, Wetzel, Wirt, Wood, and Wyoming.

Kentucky:
Allen, Anderson, Bath, Barren, Boone, Bourbon, Boyd, Bracken, Bullitt, Caldwell, Campbell, Casey, Christian, Clay, Crittenden, Daviess, Estill, Fayette, Fleming, Franklin, Gallatin, Garrard, Hancock, Hardin, Harrison, Hart, Henderson, Henry, Hopkins, Jackson, Jefferson, Jessamine, Kenton, Larue, Lawrence, Lee, Letcher, Lincoln, Livingston, Madison, Magoffin, Martin, Mason, McLean, Menifee, Mercer, Metcalfe, Montgomery, Morgan, Muhlenberg, Nelson, Nicholas, Ohio, Owen, Oldham, Owsley, Pike, Powell, Robertson, Scott, Shelby, Simpson, Spencer, Trimble, Wayne, Webster, Wolfe, and Woodford

Statewide closure:
Delaware

Delayed:
Washington, D.C.

We are actively monitoring the issue and will keep this page updated on closures.
Posted Jan 06, 2025 - 15:50 UTC