Data Status Page

This page contains information about third-party data source disruptions and delays.

Collin County, Texas – Court Processing Delays

Incident Report for Checkr Data Status

Resolved

Resolved - normal search processing has resumed
Posted Jul 15, 2026 - 03:11 UTC

Update

All issues have been resolved and normal search processing has resumed. Some searches may experience delay as the queue normalizes. Monitoring.
Posted Jul 07, 2026 - 22:15 UTC

Update

Automated search processing has resumed. Some searches are currently experiencing delays. No ETA for resolution at this time.
Posted Jun 26, 2026 - 18:18 UTC

Monitoring

Automated search processing is temporarily unavailable due to system updates. All search types are currently experiencing delays. No ETA for resolution at this time.
Posted Jun 25, 2026 - 21:20 UTC