United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Massachusetts DMV is Offline
Incident Report for Checkr US Data Status
Resolved
11/17/2021: The Massachusetts online DMV is back online and orders are able to be processed.
Posted Nov 17, 2021 - 21:22 UTC
Identified
11/17/2021: The Massachusetts online DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will update you as we learn more.
Posted Nov 17, 2021 - 16:06 UTC