United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Tarrant, TX
Incident Report for Checkr US Data Status
Resolved
3/13/2020: Court access was unavailable most of this week but is now operational again. Please continue to expect some delays while we work through the backlog.
Posted Mar 13, 2020 - 21:35 UTC
Identified
Expected Fix Date: TBD

3/9/2020: Please expect delays in Tarrant, TX as court access is currently unavailable.
Posted Mar 09, 2020 - 12:00 UTC