United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

West Virginia Statewide – Court Processing Delays

Incident Report for Checkr US Data Status

Resolved

Searches are continuing to process through a combination of automated and in-court research. Please note that some searches requiring clerk assistance may experience additional delays. The backlog is expected to fully clear by May 25th.
Posted May 13, 2026 - 00:25 UTC

Update

Automated search processing has been restored. Some searches may continue to experience delays as the remaining backlog clears.
Posted May 08, 2026 - 17:29 UTC

Monitoring

Updates to the court portal have taken some automated search processing offline. Searches may experience delays. No ETA for resolution at this time.
Posted Apr 20, 2026 - 16:52 UTC