United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Kentucky Winter Weather

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 16:31 UTC

Monitoring

Delay due to winter weather in KY resulting in several courthouses closing and many roads being slick/unsafe to drive on. Counties with court closures that require in-court research are affected and searches are not processing in the below counties at this time.
Please see affected counties below and the extent of their closure thus far:
Jefferson Closed 12/02
Oldham Closed 12/02
Carroll Closed 12/02
Henry Opening at 10 am 12/02
Trimble Opening at 10 am 12/02
Owen Closed 12/02
Daviess Closed 12/02
Hancock Closed 12/02
Meade Closed 12/02
Posted Dec 02, 2025 - 16:29 UTC