United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Maintenance] Washington AOC

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 13:40 UTC

Monitoring

WA AOC's 60 hour semi annual Disaster Recovery Test begins on March 20th. The JIS portal will be unavailable Saturday, March 22nd from 12pm-4pm (Olympia WA time). Service interruptions are expected during this time.
Posted Mar 14, 2025 - 12:56 UTC