Automated processing is resuming. Some searches may experience delays.
Posted Jun 25, 2026 - 15:38 UTC
Update
Automated processing has resumed. Some searches may experience delays as the queue normalizes
Posted Jun 16, 2026 - 20:26 UTC
Update
Maryland is currently experiencing intermittent court system access disruptions that are impacting some automated search processing. Some searches may experience delays. No ETA for resolution at this time.
Posted Jun 15, 2026 - 14:58 UTC
Update
June 11 Update: Automated processing is resuming following system instability. Some searches may experience delays. No ETA for resolution at this time.
Posted Jun 11, 2026 - 20:14 UTC
Monitoring
Maryland is currently experiencing intermittent disruptions to court system access are impacting some automated search processing. Some searches may experience delays. No ETA for resolution at this time.