United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Oct 03, 2022 - 19:23 UTC
Identified
The following DMVs will be performing scheduled maintenance this weekend:

Saturday, 10/1
- Ohio: 3-11am PT

Sunday, 10/2
- Pennsylvania: 12-6am PT
- Rhode Island: 12-2pm PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Sep 30, 2022 - 19:11 UTC