United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

San Francisco CA Superior Court Update

Incident Report for Checkr US Data Status

Resolved

The San Francisco Superior Court clerks have returned to work after the strike. Searches will continue processing as expected.
Posted Oct 29, 2024 - 16:03 UTC

Monitoring

The San Francisco Superior Court clerks are scheduled to go on a one day strike today, October 24th. We have confirmed that this will not impact searches and processing will continue as expected.
Posted Oct 24, 2024 - 16:47 UTC