[Outage] Hawaii DMV is Offline
Incident Report for Checkr Data Status
Resolved
The Hawaii DMV came back online last night and MVRs are once again processing as normal.
Posted Sep 29, 2022 - 16:01 UTC
Identified
The Hawaii DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Sep 28, 2022 - 22:27 UTC