United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

General Court Delays

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 17:08 UTC

Monitoring

Counties and States experiencing an ongoing delay due to updated processing, staffing, etc.

--AR: Union- The court clerk is out of the town until Monday 10/6 and searches are not able to be completed until they are back in office.

--AZ: Mohave - The courts have limited staffing, all searches with potential records please expect some delays.

--CA: Los Angeles- The court's PATs have been experiencing intermittent issues. Please expect delays on some orders.

--CA: Riverside- The court's PATs have been experiencing intermittent issues. Please expect delays on some orders.

--GA: Peach- The court is closed in Peach, GA due to the court being closed for a remodel from Today 10/1 - Friday 10/3. They plan to reopen on Monday 10/6.

--MI: The researchers automation is now fixed across the state, but please expect delays as the researchers catch up in all counties.
Posted Oct 01, 2025 - 19:38 UTC