United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Colorado DMV Scheduled Maintenance

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Aug 22, 2024 - 17:05 UTC

Monitoring

The Colorado DMV will be performing scheduled maintenance tomorrow from 10AM - 2PM PT. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Aug 21, 2024 - 17:05 UTC