United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Minnesota DMV Scheduled Maintenance: 11/10 - 11/13
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 16, 2020 - 18:42 UTC
Identified
Due to system modernization, the Minnesota DMV will be offline from Tuesday, Nov. 10 at 9pm Pacific until Friday, Nov. 13. MVRs in Minnesota will be unavailable during this time.
Posted Nov 09, 2020 - 17:13 UTC