United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[DELAY] - Quitman, Grenada, Leflore and Lafayette, MS

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 21:55 UTC

Update

The justices in Quitman, Grenada, Lafayette and Leflore, MS will be out Tuesday 2/11/2025 -Friday 2/14/2025 and searches will not be processed during this time. We are monitoring the situation and anticipate searches to resume as normal on 2/18/2025.
Posted Feb 12, 2025 - 20:47 UTC

Monitoring

The justice will be out Tuesday 2/11/2025 -Friday 2/14/2025 and searches will not be processed during this time. We are monitoring the situation and anticipate searches to resume as normal on 2/18/2025.
Posted Feb 10, 2025 - 16:14 UTC