United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

SC DMV Scheduled Maintenance

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted May 06, 2024 - 11:45 UTC

Identified

The SC DMV will be performing scheduled maintenance today from 6 PM EST to 10 PM EST. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted May 03, 2024 - 19:37 UTC