[Outage] PA DMV is Offline
Incident Report for Checkr Data Status
Resolved
The PA DMV is back online.
Posted Aug 02, 2022 - 17:35 UTC
Monitoring
The PA DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Aug 02, 2022 - 14:12 UTC