United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Miami, OH
Incident Report for Checkr US Data Status
Resolved
11/24/2021: The Miami, OH online index is back online and orders are able to be processed.
Posted Nov 24, 2021 - 17:04 UTC
Identified
11/16/2021: The Miami, OH online index is currently offline and there is not an ETA for when this will be back online. We will continue to monitor this and notify you of any changes. *Estimate of affected reports: 0.04%*
Posted Nov 16, 2021 - 15:48 UTC