We are experiencing delays in Lorain, Ohio due to issues in our automation. Previously we noted delays in Delaware, Wood and Lake, Ohio however those seem to have recovered. We are monitoring the situation.
Posted Feb 21, 2025 - 21:00 UTC
Update
We are currently experiencing delays in Lorain, Ohio due to issues in our automation. Previously we noted delays in Delaware, Wood and Lake, Ohio however those seem to have recovered. We are monitoring the situation.
Posted Feb 20, 2025 - 20:52 UTC
Update
We are currently experiencing delays in Delaware, Wood, Lake and Lorain Ohio due to issues in our automation. As searches are being processed manually, please anticipate delays. We are monitoring the situation.
Posted Feb 19, 2025 - 18:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2025 - 22:06 UTC
Investigating
We are currently experiencing delays in Delaware, Wood, Lake and Lorain Ohio due to issues in our automation. As searches are being processed manually, please anticipate delays. We are monitoring the situation.